Why is the "IPv6 Route" switch designed to control all the IPv6 requests instead of only requests to the proxy?



Since Instagram won’t fall back to IPv4 as the IPv6 link doesn’t really work on my remote server, I choose to disable “IPv6 Router” in the setting to use Instagram normally. But I find I cannot open any IPv6 websites in Mainland China, using direct (non-proxy) connections. However, my device has an IPv6 address provided by the local ISP.

I wonder how I can keep domestic IPv4 and IPv6 connection as well as IPv4-only connection to the remote server.

Thank you.


A third-party bug of Google Chrome or Android System? Could you please give me an explanation before closing my issue? If you use Firefox, the issue will still exist. And Google FCM won’t try through IPv6 if I disable IPv6 router (in my rules, Google FCM is forced to connect directly).


This is intentional.