Fix shadowsocks package on Guix

The shadowsocks package does not work in Guix System, it has not been upgraded for a long time, and Guix developers do not know much about it and can not solve the problem. Please fix this problem, thanks.