Can't build project sucessful in AndroidStudio,Help me ,please


#1

My build environment:

  • AndroidStudio version:3.6.3
  • AndroidStudio Plugin version:3.5.0
  • Gradle version:5.51.when i use the default setings, the androidStudio will error,err message is “Gradle max support is 4.1”,so a use the 3.5.0 plugin,and 5.5 gradle.2.now,error message info is follow:

Task :buildSrc:compileKotlin FAILED
The kotlin-dsl plugin applied to project ‘:buildSrc’ enables experimental Kotlin compiler features. For more information see https://docs.gradle.org/5.5/userguide/kotlin_dsl.html#sec:kotlin-dsl_plugin
e: F:\Code\Android\shadowsocks-android\buildSrc\src\main\kotlin\Helpers.kt: (3, 33): Unresolved reference: AbstractAppExtension
e: F:\Code\Android\shadowsocks-android\buildSrc\src\main\kotlin\Helpers.kt: (56, 24): Unresolved reference: isCoreLibraryDesugaringEnabled
e: F:\Code\Android\shadowsocks-android\buildSrc\src\main\kotlin\Helpers.kt: (89, 49): Unresolved reference: AbstractAppExtension
e: F:\Code\Android\shadowsocks-android\buildSrc\src\main\kotlin\Helpers.kt: (90, 24): Unresolved reference: outputs
e: F:\Code\Android\shadowsocks-android\buildSrc\src\main\kotlin\Helpers.kt: (92, 46): Unresolved reference: versionCode


#2

Update Android studio to 4.1+.