Dns floods with shadowsocks-android


#1

Dear folks:
I’m using the latest version of shadowsocks-andorid; but now I’m have a trouble with the version. Personally, I don’t want the app forward and dns request to remote server, so I did configure or enable any option for dns forwarding. Even so, when I check the log info on the remote server, I still find boatloads of dns requests to dns.google:53. I wanna the app just use the local dns server as I have no any dns pollution problem. Anybody now how disable this forwarding behavior? It is really annoying. Any suggestions will be appreciated.


#2

This feature is not supported by shadowsocks-android. I am not sure why you need that but feel free to fork the repo and change the behavior to tune for your needs.


#3

Hi mygod.
Thanks for your reply.
Previous version did not have such issue, would not send any dns request to remote server; I dont know the latest version changed the configuration.